re = /^[tT="](?!0{1,3}$)[0-9]{1,3}$/m
str = 'T="100
T789
T001
T000
t00
t012
t000
t0
t
t1231
a456'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end