package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?|.*?\b(hello)\b|.*?\b(hey)\b|.*?\b(hi)\b)`)
var str = `hi hey hello
hi hey
hi`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}