$re = '/(?|.*?\b(hello)\b|.*?\b(hey)\b|.*?\b(hi)\b)/m';
$str = 'hi hey hello
hi hey
hi';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);