re = /(?|.*?\b(hello)\b|.*?\b(hey)\b|.*?\b(hi)\b)/m
str = 'hi hey hello
hi hey
hi'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end