// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?|.*?\b(hello)\b|.*?\b(hey)\b|.*?\b(hi)\b)").unwrap();
let string = "hi hey hello
hi hey
hi";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}