#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?P<username>.+?)\s+(?P<email>[\S]+\@[\S]+|\[email protected]+)\s+(?P<address>.+?)\s+(?P<hash>[a-zA-Z0-9]{32})\:(?P<salt>.+?)$"
Local $sString = "Nathan Mallett-Sarine blazee14@gmail.com 1795 LONGUEUIL Quebec CA J4J3N3 5145033521 4226ab3509a31f80bdb715e00ca6a00b:dHffX" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")