import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?P<username>.+?)\\s+(?P<email>[\\S]+\\@[\\S]+|\\[email protected]+)\\s+(?P<address>.+?)\\s+(?P<hash>[a-zA-Z0-9]{32})\\:(?P<salt>.+?)$";
final String string = "Nathan Mallett-Sarine blazee14@gmail.com 1795 LONGUEUIL Quebec CA J4J3N3 5145033521 4226ab3509a31f80bdb715e00ca6a00b:dHffX\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}