const regex = new RegExp('^(?P<username>.+?)\\s+(?P<email>[\\S]+\\@[\\S]+|\\[email protected]+)\\s+(?P<address>.+?)\\s+(?P<hash>[a-zA-Z0-9]{32})\\:(?P<salt>.+?)$', 'm')
const str = `Nathan Mallett-Sarine blazee14@gmail.com 1795 LONGUEUIL Quebec CA J4J3N3 5145033521 4226ab3509a31f80bdb715e00ca6a00b:dHffX
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}