using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?P<username>.+?)\s+(?P<email>[\S]+\@[\S]+|\[email protected]+)\s+(?P<address>.+?)\s+(?P<hash>[a-zA-Z0-9]{32})\:(?P<salt>.+?)$";
string input = @"Nathan Mallett-Sarine blazee14@gmail.com 1795 LONGUEUIL Quebec CA J4J3N3 5145033521 4226ab3509a31f80bdb715e00ca6a00b:dHffX
";
RegexOptions options = RegexOptions.Multiline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}