$re = '/# Section header
^ \s* \[ \s* \w+ \s* \] \s* $
# Section items
(?:
^ (?:
# key = value
\s* \w+ \s* = \s* [\w\s]+ \s*
|
# comment line
\s* \# .* $
|
# blank line
\s*
) $
) */m';
$str = '[ keybinds ]
# comment
bksp = reload
# comment
space = jump # not comment
[settings ]
resolution = 640 x 480
max_framerate = 24
[character]
# This is a comment. This section is empty.
[weapons]
[server]
login = hexology
password = my password # is not a comment';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);