// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)# Section header
^ \s* \[ \s* \w+ \s* \] \s* $
# Section items
(?:
^ (?:
# key = value
\s* \w+ \s* = \s* [\w\s]+ \s*
|
# comment line
\s* \# .* $
|
# blank line
\s*
) $
) *").unwrap();
let string = "[ keybinds ]
# comment
bksp = reload
# comment
space = jump # not comment
[settings ]
resolution = 640 x 480
max_framerate = 24
[character]
# This is a comment. This section is empty.
[weapons]
[server]
login = hexology
password = my password # is not a comment";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}