import Foundation
let pattern = ##"""
# Section header
^ \s* \[ \s* \w+ \s* \] \s* $
# Section items
(?:
^ (?:
# key = value
\s* \w+ \s* = \s* [\w\s]+ \s*
|
# comment line
\s* \# .* $
|
# blank line
\s*
) $
) *
"""##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
[ keybinds ]
# comment
bksp = reload
# comment
space = jump # not comment
[settings ]
resolution = 640 x 480
max_framerate = 24
[character]
# This is a comment. This section is empty.
[weapons]
[server]
login = hexology
password = my password # is not a comment
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)