#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[+-]?(?:\.\d+|\d+(?:\.\d+)?)$"
Local $sString = "234.2344" & @CRLF & _
"" & @CRLF & _
"+.3456468" & @CRLF & _
"" & @CRLF & _
"5.34.0" & @CRLF & _
"" & @CRLF & _
"4+345.0 "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")