package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[+-]?(?:\.\d+|\d+(?:\.\d+)?)$`)
var str = `234.2344
+.3456468
5.34.0
4+345.0 `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}