$re = '/^[+-]?(?:\.\d+|\d+(?:\.\d+)?)$/m';
$str = '234.2344
+.3456468
5.34.0
4+345.0 ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);