#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:\\\"|[^<>\"])+(?=(?:<[^>]*>)?\"})"
Local $sString = " {"title_available" "text1"}" & @CRLF & _
" {"title_value" "<c(20a601)>text2"}" & @CRLF & _
" {"tags"" & @CRLF & _
" {"all" "text3"}" & @CRLF & _
" {"ignore" "text4"}" & @CRLF & _
" {"chargeFactor" "text5 %1%"}" & @CRLF & _
" {"resourceSpeed" "%1% text6"}" & @CRLF & _
" }" & @CRLF & _
" {"rules" "bla-bla-bla\n\n \"BLA\" bla-bla-bla."}" & @CRLF & _
" {"id1" "<c(c3baae)>text7</c>"}" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")