import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\\\\\\"|[^<>\\\"])+(?=(?:<[^>]*>)?\\\"\\})";
final String string = " {\"title_available\" \"text1\"}\n"
+ " {\"title_value\" \"<c(20a601)>text2\"}\n"
+ " {\"tags\"\n"
+ " {\"all\" \"text3\"}\n"
+ " {\"ignore\" \"text4\"}\n"
+ " {\"chargeFactor\" \"text5 %1%\"}\n"
+ " {\"resourceSpeed\" \"%1% text6\"}\n"
+ " }\n"
+ " {\"rules\" \"bla-bla-bla\\n\\n \\\"BLA\\\" bla-bla-bla.\"}\n"
+ " {\"id1\" \"<c(c3baae)>text7</c>\"}\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}