import Foundation
let pattern = #"(?:\\\"|[^<>\"])+(?=(?:<[^>]*>)?\"})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
{"title_available" "text1"}
{"title_value" "<c(20a601)>text2"}
{"tags"
{"all" "text3"}
{"ignore" "text4"}
{"chargeFactor" "text5 %1%"}
{"resourceSpeed" "%1% text6"}
}
{"rules" "bla-bla-bla\n\n \"BLA\" bla-bla-bla."}
{"id1" "<c(c3baae)>text7</c>"}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)