$re = '/(?:\\\\\"|[^<>\"])+(?=(?:<[^>]*>)?\"})/m';
$str = ' {"title_available" "text1"}
{"title_value" "<c(20a601)>text2"}
{"tags"
{"all" "text3"}
{"ignore" "text4"}
{"chargeFactor" "text5 %1%"}
{"resourceSpeed" "%1% text6"}
}
{"rules" "bla-bla-bla\\n\\n \\"BLA\\" bla-bla-bla."}
{"id1" "<c(c3baae)>text7</c>"}
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);