# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?=\b\d+\))/\n/g;t' <<< "1) test 1 22) test 2 333) test 3 4444) test 4 55555) test 5"