re = /(?=\b\d+\))/
str = '1) test 1 22) test 2 333) test 3 4444) test 4 55555) test 5'
subst = '\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result