import re
regex = re.compile(r"(?=\b\d+\))")
test_str = "1) test 1 22) test 2 333) test 3 4444) test 4 55555) test 5"
subst = "\\n"
result = regex.sub(subst, test_str)
if result:
print(result)