use strict;
my $str = '1) test 1 22) test 2 333) test 3 4444) test 4 55555) test 5';
my $regex = qr/(?=\b\d+\))/p;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";