use strict;
my $str = 'google';
my $regex = qr/\B/mp;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";