package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)CCDBNUM="([^"]+)"`)
var str = `String str= "<decision CCDBNUM="1111111" adddate="20180112"><decision CCDBNUM="2222222" adddate="20180114">";
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}