re = /CCDBNUM="([^"]+)"/m
str = 'String str= "<decision CCDBNUM="1111111" adddate="20180112"><decision CCDBNUM="2222222" adddate="20180114">";
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end