$re = '/CCDBNUM="([^"]+)"/m';
$str = 'String str= "<decision CCDBNUM="1111111" adddate="20180112"><decision CCDBNUM="2222222" adddate="20180114">";
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);