# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[^A-Za-z0-9#]+//g;t' <<< "Address
#1234....."