use strict;
my $str = 'Address
#1234.....';
my $regex = qr/[^A-Za-z0-9#]+/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";