#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "[^A-Za-z0-9#]+"
Local $sString = "Address " & @CRLF & _
"#1234....."
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)