using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(0[1-9]|[1-2][0-9]|3[0-1])\.\s*(0[1-9]|1[0-2])\.\s*[0-9]{4}$";
string input = @"01.12.1990
01. 12. 1990";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}