import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(0[1-9]|[1-2][0-9]|3[0-1])\\.\\s*(0[1-9]|1[0-2])\\.\\s*[0-9]{4}$";
final String string = "01.12.1990\n"
+ "01. 12. 1990";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}