re = /^(0[1-9]|[1-2][0-9]|3[0-1])\.\s*(0[1-9]|1[0-2])\.\s*[0-9]{4}$/m
str = '01.12.1990
01. 12. 1990'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end