package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(0[1-9]|[1-2][0-9]|3[0-1])\.\s*(0[1-9]|1[0-2])\.\s*[0-9]{4}$`)
var str = `01.12.1990
01. 12. 1990`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}