using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https?\:\/\/(?!backbone)\S+\.com(?=(?:(?!http)[^])*https?\:\/\/backbone.js)";
string input = @"dfjSKsfkfkSFKfdvsfdvsdv https://text.com from https://test2.com sdjgdsdh https://backbone.js from jfsjfskf https://backbone.js jsvdywfiwqkbfs sfgsaifiwf sfasfk https://fggfgf.com";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}