import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https?\\:\\/\\/(?!backbone)\\S+\\.com(?=(?:(?!http)[^])*https?\\:\\/\\/backbone.js)";
final String string = "dfjSKsfkfkSFKfdvsfdvsdv https://text.com from https://test2.com sdjgdsdh https://backbone.js from jfsjfskf https://backbone.js jsvdywfiwqkbfs sfgsaifiwf sfasfk https://fggfgf.com";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}