import re
regex = re.compile(r"https?\:\/\/(?!backbone)\S+\.com(?=(?:(?!http)[^])*https?\:\/\/backbone.js)")
test_str = "dfjSKsfkfkSFKfdvsfdvsdv https://text.com from https://test2.com sdjgdsdh https://backbone.js from jfsjfskf https://backbone.js jsvdywfiwqkbfs sfgsaifiwf sfasfk https://fggfgf.com"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")