const regex = /https?\:\/\/(?!backbone)\S+\.com(?=(?:(?!http)[^])*https?\:\/\/backbone.js)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('https?\\:\\\/\\\/(?!backbone)\\S+\\.com(?=(?:(?!http)[^])*https?\\:\\\/\\\/backbone.js)', 'g')
const str = `dfjSKsfkfkSFKfdvsfdvsdv https://text.com from https://test2.com sdjgdsdh https://backbone.js from jfsjfskf https://backbone.js jsvdywfiwqkbfs sfgsaifiwf sfasfk https://fggfgf.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}