# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*([A-Za-z])[^a-z]+$/$1/igm;t' <<< "Job number 45752 Subtotal price $937.50
Job number 7852 Subtotal amount $637.50
Job number 42 Subtotal test $427.50
Job number 47592 Subtotal sample $976.50 "