using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*([A-Za-z])[^a-z]+$";
string substitution = @"$1";
string input = @"Job number 45752 Subtotal price $937.50
Job number 7852 Subtotal amount $637.50
Job number 42 Subtotal test $427.50
Job number 47592 Subtotal sample $976.50 ";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}