re = /.*([A-Za-z])[^a-z]+$/im
str = 'Job number 45752 Subtotal price $937.50
Job number 7852 Subtotal amount $637.50
Job number 42 Subtotal test $427.50
Job number 47592 Subtotal sample $976.50 '
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result