import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*([A-Za-z])[^a-z]+$";
final String string = "Job number 45752 Subtotal price $937.50 \n"
+ "Job number 7852 Subtotal amount $637.50 \n"
+ "Job number 42 Subtotal test $427.50 \n"
+ "Job number 47592 Subtotal sample $976.50 ";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}