use strict;
my $str = 'one two
one
two';
my $regex = qr/(\s){2,}/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";