using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:([\t ])\1{1,})|(?:(\n\n)\n+)";
string substitution = @"$1$2";
string input = @"one two
one
two";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}