$re = '/(?:([\t ])\1{1,})|(?:(\n\n)\n+)/m';
$str = 'one two
one
two';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;