re = /(?:([\t ])\1{1,})|(?:(\n\n)\n+)/m
str = 'one two
one
two'
subst = '$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result