const regex = /(?:([\t ])\1{1,})|(?:(\n\n)\n+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:([\\t ])\\1{1,})|(?:(\\n\\n)\\n+)', 'gm')
const str = `one two
one
two`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);