# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^.*\\/([^\/]*)-.*/\1/gm;t' <<< "http://www.mega.pk/**washingmachine**-dawlance/
http://www.mega.pk/**washingmachine**-haier/
http://www.mega.pk/**airconditioners**-acson/
http://www.mega.pk/**airconditioners**-lg/
http://www.mega.pk/**airconditioners**-samsung/"