import re
regex = re.compile(r"^.*\/([^/]*)-.*", flags=re.MULTILINE)
test_str = ("http://www.mega.pk/**washingmachine**-dawlance/\n"
"http://www.mega.pk/**washingmachine**-haier/\n"
"http://www.mega.pk/**airconditioners**-acson/\n"
"http://www.mega.pk/**airconditioners**-lg/\n"
"http://www.mega.pk/**airconditioners**-samsung/")
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)