re = /^.*\/([^\/]*)-.*/m
str = 'http://www.mega.pk/**washingmachine**-dawlance/
http://www.mega.pk/**washingmachine**-haier/
http://www.mega.pk/**airconditioners**-acson/
http://www.mega.pk/**airconditioners**-lg/
http://www.mega.pk/**airconditioners**-samsung/'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result